System requirements

Please review the frequently asked questions below.
Not a patient? Visit Health Care Provider Help.

System requirements

  • Minimum

    • Microsoft Internet Explorer v6.0
    • Adobe Acrobat Reader v6.0

    Recommended

    • Adobe Acrobat Reader v9.3.4 or above
    • High-speed internet connection (DSL, cable, or T1)
    • Microsoft Office Excel 2000 or later version
    • Laser printer 

    Was this helpful?

    Was this information helpful?
    5
    5
    Still need help? Contact Us
  • An internet-capable PC and a laser printer 

    Was this helpful?

    Was this information helpful?
    6
    6
    Still need help? Contact Us

Still need help? Contact Us.

Frequently Asked Questions